<!DOCTYPE html>
<html lang="en-US">
<head>
<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width" />
<title>A match-winner, Afridi on Pakistan player who always gives 100 percent</title>
<link rel="profile" href="http://gmpg.org/xfn/11" />
<link rel="pingback" href="https://battingwithbimal.com/xmlrpc.php" />
<!--[if lt IE 9]>
<script src="https://battingwithbimal.com/wp-content/themes/visual/js/html5.js" type="text/javascript"></script>
<![endif]-->

<script type="text/javascript">
  WebFontConfig = {"google":{"families":["Montserrat:r:latin,latin-ext","Montserrat:r,i,b,bi:latin,latin-ext"]}};
  (function() {
    var wf = document.createElement('script');
    wf.src = 'https://battingwithbimal.com/wp-content/mu-plugins/wpcomsh/vendor/automattic/custom-fonts/js/webfont.js';
    wf.type = 'text/javascript';
    wf.async = 'true';
    var s = document.getElementsByTagName('script')[0];
    s.parentNode.insertBefore(wf, s);
	})();
</script><style id="jetpack-custom-fonts-css">.wf-active .site-title{font-family:"Montserrat",sans-serif;font-style:normal;font-weight:400}.wf-active body, .wf-active button, .wf-active input, .wf-active select, .wf-active textarea{font-family:"Montserrat",sans-serif}.wf-active .entry-title{font-family:"Montserrat",sans-serif;font-style:normal;font-weight:400}.wf-active .entry-content h1, .wf-active .entry-content h2, .wf-active .entry-content h3, .wf-active .entry-content h4, .wf-active .entry-content h5, .wf-active .entry-content h6{font-weight:400;font-style:normal}.wf-active .entry-content h1, .wf-active .entry-content h2{font-style:normal;font-weight:400}.wf-active .entry-content h3{font-style:normal;font-weight:400}.wf-active .entry-content h4, .wf-active .entry-content h5{font-style:normal;font-weight:400}.wf-active .page-header .page-title{font-style:normal;font-weight:400}.wf-active #reply-title, .wf-active .comments-title, .wf-active .nocomments{font-style:normal;font-weight:400}.wf-active .widget-title{font-style:normal;font-weight:400}</style>
		<style type="text/css">
					.heateor_sss_button_instagram span.heateor_sss_svg,a.heateor_sss_instagram span.heateor_sss_svg{background:radial-gradient(circle at 30% 107%,#fdf497 0,#fdf497 5%,#fd5949 45%,#d6249f 60%,#285aeb 90%)}
											.heateor_sss_horizontal_sharing .heateor_sss_svg,.heateor_sss_standard_follow_icons_container .heateor_sss_svg{
							color: #fff;
						border-width: 0px;
			border-style: solid;
			border-color: transparent;
		}
					.heateor_sss_horizontal_sharing .heateorSssTCBackground{
				color:#666;
			}
					.heateor_sss_horizontal_sharing span.heateor_sss_svg:hover,.heateor_sss_standard_follow_icons_container span.heateor_sss_svg:hover{
						border-color: transparent;
		}
		.heateor_sss_vertical_sharing span.heateor_sss_svg,.heateor_sss_floating_follow_icons_container span.heateor_sss_svg{
							color: #fff;
						border-width: 0px;
			border-style: solid;
			border-color: transparent;
		}
				.heateor_sss_vertical_sharing .heateorSssTCBackground{
			color:#666;
		}
						.heateor_sss_vertical_sharing span.heateor_sss_svg:hover,.heateor_sss_floating_follow_icons_container span.heateor_sss_svg:hover{
						border-color: transparent;
		}
		@media screen and (max-width:783px) {.heateor_sss_vertical_sharing{display:none!important}}div.heateor_sss_mobile_footer{display:none;}@media screen and (max-width:783px){div.heateor_sss_bottom_sharing .heateorSssTCBackground{background-color:white}div.heateor_sss_bottom_sharing{width:100%!important;left:0!important;}div.heateor_sss_bottom_sharing a{width:16.666666666667% !important;}div.heateor_sss_bottom_sharing .heateor_sss_svg{width: 100% !important;}div.heateor_sss_bottom_sharing div.heateorSssTotalShareCount{font-size:1em!important;line-height:28px!important}div.heateor_sss_bottom_sharing div.heateorSssTotalShareText{font-size:.7em!important;line-height:0px!important}div.heateor_sss_mobile_footer{display:block;height:40px;}.heateor_sss_bottom_sharing{padding:0!important;display:block!important;width:auto!important;bottom:-2px!important;top: auto!important;}.heateor_sss_bottom_sharing .heateor_sss_square_count{line-height:inherit;}.heateor_sss_bottom_sharing .heateorSssSharingArrow{display:none;}.heateor_sss_bottom_sharing .heateorSssTCBackground{margin-right:1.1em!important}}		</style>
		<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />
<!-- Jetpack Site Verification Tags -->
<meta name="google-site-verification" content="YZtMGt9mI-0exFsBkwtumsOt2hRTIPzqUpanw4D79EY" />
<meta name="yandex-verification" content="e5e1b3e4b283e4f5" />

	<!-- This site is optimized with the Yoast SEO plugin v18.9 - https://yoast.com/wordpress/plugins/seo/ -->
	<meta name="description" content="We all know he&#039;s a match-winner, Shaheen Shah Afridi said about a Pakistan player who always gives 100 percent." />
	<link rel="canonical" href="https://battingwithbimal.com/2022/05/19/we-all-know-hes-a-match-winner-shaheen-shah-afridi-on-pakistan-player-who-always-gives-100-percent/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="A match-winner, Afridi on Pakistan player who always gives 100 percent" />
	<meta property="og:description" content="We all know he&#039;s a match-winner, Shaheen Shah Afridi said about a Pakistan player who always gives 100 percent." />
	<meta property="og:url" content="https://battingwithbimal.com/2022/05/19/we-all-know-hes-a-match-winner-shaheen-shah-afridi-on-pakistan-player-who-always-gives-100-percent/" />
	<meta property="og:site_name" content="Batting with Bimal" />
	<meta property="article:publisher" content="https://www.facebook.com/battingwithbimal/" />
	<meta property="article:published_time" content="2022-05-18T22:13:20+00:00" />
	<meta property="og:image" content="https://battingwithbimal.com/wp-content/uploads/2020/09/297368.jpg" />
	<meta name="twitter:card" content="summary" />
	<meta name="twitter:creator" content="@BimalMirwani" />
	<meta name="twitter:site" content="@BimalMirwani" />
	<meta name="twitter:label1" content="Written by" />
	<meta name="twitter:data1" content="bimalmirwani" />
	<meta name="twitter:label2" content="Est. reading time" />
	<meta name="twitter:data2" content="2 minutes" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://battingwithbimal.com/#website","url":"https://battingwithbimal.com/","name":"Batting with Bimal","description":"Pakistan cricket news, views and highlights","potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://battingwithbimal.com/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","inLanguage":"en-US","@id":"https://battingwithbimal.com/2022/05/19/we-all-know-hes-a-match-winner-shaheen-shah-afridi-on-pakistan-player-who-always-gives-100-percent/#primaryimage","url":"https://i0.wp.com/battingwithbimal.com/wp-content/uploads/2020/09/297368.jpg?fit=1400%2C2100&ssl=1","contentUrl":"https://i0.wp.com/battingwithbimal.com/wp-content/uploads/2020/09/297368.jpg?fit=1400%2C2100&ssl=1","width":1400,"height":2100,"caption":"Shaheen Shah Afridi: \"He has given his best, we all know that he is a match-winner for our side\""},{"@type":"WebPage","@id":"https://battingwithbimal.com/2022/05/19/we-all-know-hes-a-match-winner-shaheen-shah-afridi-on-pakistan-player-who-always-gives-100-percent/#webpage","url":"https://battingwithbimal.com/2022/05/19/we-all-know-hes-a-match-winner-shaheen-shah-afridi-on-pakistan-player-who-always-gives-100-percent/","name":"A match-winner, Afridi on Pakistan player who always gives 100 percent","isPartOf":{"@id":"https://battingwithbimal.com/#website"},"primaryImageOfPage":{"@id":"https://battingwithbimal.com/2022/05/19/we-all-know-hes-a-match-winner-shaheen-shah-afridi-on-pakistan-player-who-always-gives-100-percent/#primaryimage"},"datePublished":"2022-05-18T22:13:20+00:00","dateModified":"2022-05-18T22:13:20+00:00","author":{"@id":"https://battingwithbimal.com/#/schema/person/07738249525c6592daa6f25521087ee8"},"description":"We all know he's a match-winner, Shaheen Shah Afridi said about a Pakistan player who always gives 100 percent.","breadcrumb":{"@id":"https://battingwithbimal.com/2022/05/19/we-all-know-hes-a-match-winner-shaheen-shah-afridi-on-pakistan-player-who-always-gives-100-percent/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://battingwithbimal.com/2022/05/19/we-all-know-hes-a-match-winner-shaheen-shah-afridi-on-pakistan-player-who-always-gives-100-percent/"]}]},{"@type":"BreadcrumbList","@id":"https://battingwithbimal.com/2022/05/19/we-all-know-hes-a-match-winner-shaheen-shah-afridi-on-pakistan-player-who-always-gives-100-percent/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https://battingwithbimal.com/"},{"@type":"ListItem","position":2,"name":"We all know he&#8217;s a match-winner, Shaheen Shah Afridi on Pakistan player who always gives 100 percent"}]},{"@type":"Person","@id":"https://battingwithbimal.com/#/schema/person/07738249525c6592daa6f25521087ee8","name":"bimalmirwani","image":{"@type":"ImageObject","inLanguage":"en-US","@id":"https://battingwithbimal.com/#/schema/person/image/","url":"https://secure.gravatar.com/avatar/2f2f68d42d41c1934260dce0d22959d2?s=96&d=identicon&r=g","contentUrl":"https://secure.gravatar.com/avatar/2f2f68d42d41c1934260dce0d22959d2?s=96&d=identicon&r=g","caption":"bimalmirwani"},"description":"Born and lived in Hong Kong for all my life before coming to Kingston University as a journalism undergraduate student. This blog will be centred around the topic of international cricket"}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//secure.gravatar.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//widgets.wp.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//0.gravatar.com' />
<link rel='dns-prefetch' href='//1.gravatar.com' />
<link rel='dns-prefetch' href='//2.gravatar.com' />
<link rel='dns-prefetch' href='//jetpack.wordpress.com' />
<link rel='dns-prefetch' href='//public-api.wordpress.com' />
<link rel='dns-prefetch' href='//i0.wp.com' />
<link rel='dns-prefetch' href='//c0.wp.com' />
<link rel="alternate" type="application/rss+xml" title="Batting with Bimal &raquo; Feed" href="https://battingwithbimal.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Batting with Bimal &raquo; Comments Feed" href="https://battingwithbimal.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Batting with Bimal &raquo; We all know he&#8217;s a match-winner, Shaheen Shah Afridi on Pakistan player who always gives 100 percent Comments Feed" href="https://battingwithbimal.com/2022/05/19/we-all-know-hes-a-match-winner-shaheen-shah-afridi-on-pakistan-player-who-always-gives-100-percent/feed/" />
<script type="text/javascript">
window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/battingwithbimal.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.9.3"}};
/*! This file is auto-generated */
!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([10084,65039,8205,55357,56613],[10084,65039,8203,55357,56613])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 0.07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='all-css-26537f52113507efe169afc1f601a703' href='https://battingwithbimal.com/_static/??-eJyNUttuwjAM/aFl2YZAe5n2KZObGAh1LoodSv9+KaVaBXTwEvl2ju3jdEmZGASD6ERl5wLrFIlUlzRY74I2zLqhaNrXar10t+UHlASm1T7aQsg6I4GgVSmyXHkThQuGiq21A7l1LGMHRa7JkHvN0hO+1u43gANrj9YBEvphiLmTCHrMinAHpn8KXXNzf46ZtvRFTYt2yUTPe33EYGPWUCR6EHFGC55kZFKdszsUdd5g3O8SGWqWJJwUT6WhSjeghH/O0TH0CLit8T/M2VuCgLWKEbLZK4l16FDmbd0x5v6SvyfH0tHJtfUd73YFkX0Vl/XRcQG6X7LEyqVhk10SF8OV9yzFqD7rLRhsYhz+WFuN0/+DMDBXGaJxQIr3kHEu0m32wZmmoQbwxR5Kv/3X+2b98blZva3Wv3qdWuw=' type='text/css' media='all' />
<style id='wp-block-library-inline-css'>
.has-text-align-justify{text-align:justify;}
</style>
<style id='global-styles-inline-css'>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</style>
<link crossorigin="anonymous" rel='stylesheet' id='visual-raleway-css'  href='https://fonts.googleapis.com/css?family=Raleway%3A400%2C700&#038;ver=5.9.3' media='all' />
<style id='jetpack-global-styles-frontend-style-inline-css'>
:root { --font-headings: unset; --font-base: unset; --font-headings-default: -apple-system,BlinkMacSystemFont,"Segoe UI",Roboto,Oxygen-Sans,Ubuntu,Cantarell,"Helvetica Neue",sans-serif; --font-base-default: -apple-system,BlinkMacSystemFont,"Segoe UI",Roboto,Oxygen-Sans,Ubuntu,Cantarell,"Helvetica Neue",sans-serif;}
</style>
<script id='jetpack_related-posts-js-extra'>
var related_posts_js_options = {"post_heading":"h4"};
</script>
<script type='text/javascript'  src='https://battingwithbimal.com/wp-content/plugins/jetpack/_inc/build/related-posts/related-posts.min.js?m=1638896208'></script>
<script src='https://battingwithbimal.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script>
<script id='media-video-jwt-bridge-js-extra'>
var videopressAjax = {"ajaxUrl":"https:\/\/battingwithbimal.com\/wp-admin\/admin-ajax.php","bridgeUrl":"https:\/\/battingwithbimal.com\/wp-content\/plugins\/jetpack\/modules\/videopress\/js\/videopress-token-bridge.js","post_id":"159158"};
</script>
<script type='text/javascript'  src='https://battingwithbimal.com/_static/??-eJx1TlsKwjAQvJDbaLH1SzyKtMkSNt0kax4t3t5YBb+EgWEG5rEJUNBcDWblGh4V0/NL4MmmqWDnKXQuHzYBHUPBUJRwtRSyksgMmyipM5N+N5R8382P8yfmsMikF+WjqdyWVzIYJWHeT/wUlLhggDmRsdi6bv56God+OPfH8fICbzxGJQ=='></script>
<link rel="https://api.w.org/" href="https://battingwithbimal.com/wp-json/" /><link rel="alternate" type="application/json" href="https://battingwithbimal.com/wp-json/wp/v2/posts/159158" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://battingwithbimal.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://battingwithbimal.com/wp-includes/wlwmanifest.xml" /> 

<link rel='shortlink' href='https://wp.me/p2ePmX-Fp4' />
<link rel="alternate" type="application/json+oembed" href="https://battingwithbimal.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fbattingwithbimal.com%2F2022%2F05%2F19%2Fwe-all-know-hes-a-match-winner-shaheen-shah-afridi-on-pakistan-player-who-always-gives-100-percent%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://battingwithbimal.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fbattingwithbimal.com%2F2022%2F05%2F19%2Fwe-all-know-hes-a-match-winner-shaheen-shah-afridi-on-pakistan-player-who-always-gives-100-percent%2F&#038;format=xml" />
<!-- Global site tag (gtag.js) - Google Analytics -->
<script async src="https://www.googletagmanager.com/gtag/js?id=G-GV521V1E8M"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'G-GV521V1E8M');
</script>


<div style="width:100%;font-size:11px;line-height:11px;font-family:Verdana,Arial,Helvetica,sans-serif;color:#ddd;text-align:center" ><a rel="nofollow" href="http://www.newsnow.co.uk/h/Sport/Cricket" target="newsnow" title="Click here for more Cricket news from NewsNow" style="text-decoration:none;border:0;" rel="nofollow" ><img src="https://battingwithbimal.com/wp-content/uploads/2018/02/newsnow_aw.gif" style="width:117px;height:47px;border:1px;display:inline-block;text-align: center;padding-bottom:2px" alt="As featured on NewsNow: Cricket news"/></a ></br><a rel="nofollow" href="http://www.newsnow.co.uk/h/Sport/Cricket" target="newsnow" title="Click here for more Cricket news from NewsNow" style="color:#ddd;text-decoration:none;border:0;" rel="nofollow"></a ><a href="http://www.newsnow.co.uk/h/Sport/Cricket" target="newsnow" title="Click here for more Cricket news from NewsNow" style="color:#ddd;text-decoration:none;border:0;" rel="nofollow">Cricket News</a ><a rel="nofollow" href="http://www.newsnow.co.uk/h/Sport/Cricket" target="newsnow" title="Click here for more Cricket news from NewsNow" style="color:#ddd;text-decoration:none;border:0;" rel="nofollow"> 24/7</a></div><style type='text/css'>img#wpstats{display:none}</style>
		<style type="text/css">
			.site-title a,
		.site-description {
			color: #1e73be;
		}
		</style>
	<style type="text/css" id="custom-background-css">
body.custom-background { background-color: #000000; }
</style>
	<link rel="amphtml" href="https://battingwithbimal.com/2022/05/19/we-all-know-hes-a-match-winner-shaheen-shah-afridi-on-pakistan-player-who-always-gives-100-percent/?amp"><style type="text/css" id="custom-colors-css">footer.entry-meta,.entry-header{border-color:#333}footer.entry-meta,.entry-header{border-color:rgba(51,51,51,.1)}.page-header,.wp-caption{border-color:#333}.page-header,.wp-caption{border-color:rgba(51,51,51,.1)}.navigation-main a,.navigation-main li:last-of-type a,.navigation-main ul ul li a{border-color:#363636}.navigation-main a,.navigation-main li:last-of-type a,.navigation-main ul ul li a{border-color:rgba(54,54,54,.1)}.entry-content,.entry-summary{border-top-color:#363636}.entry-content,.entry-summary{border-top-color:rgba(54,54,54,.05)}.widget-title{border-bottom-color:#363636}.widget-title{border-bottom-color:rgba(54,54,54,.1)}.comment-list:after{border-color:#363636}.comment-list:after{border-color:rgba(54,54,54,.1)}.entry-content,.entry-summary{border-color:#161616}.entry-content,.entry-summary{border-color:rgba(22,22,22,.1)}.navigation-main{border-right-color:#161616}.navigation-main{border-right-color:rgba(22,22,22,.1)}.navigation-main ul ul li{border-color:#161616}.navigation-main ul ul li{border-color:rgba(22,22,22,.1)}.navigation-main li{border-color:#161616}.navigation-main li{border-color:rgba(22,22,22,.1)}.widget-title:after{border-color:#161616}.widget-title:after{border-color:rgba(22,22,22,.05)}.navigation-main ul ul li a:hover{border-color:#161616}.navigation-main ul ul li a:hover{border-color:rgba(22,22,22,.1)}body{color:#ccc}pre{color:#ccc}hr{color:#ccc}hr{color:rgba(204,204,204,.5)}footer.entry-meta a,footer.entry-meta a:visited{color:#ccc}.entry-meta a,.entry-meta a:visited{color:#ddd}.site-footer a,.site-footer a:visited{color:#ddd}.navigation-main a,.navigation-main a:visited{color:#ddd}#comments a{color:#ddd}[class*="navigation"] .nav-previous a,[class*="navigation"] .nav-next a{color:#ddd}.navigation-main ul ul{border-color:#222}.navigation-main ul ul{border-color:rgba(34,34,34,.1)}button,html input[type="button"],input[type="reset"],input[type="submit"]{border-color:#222}button,html input[type="button"],input[type="reset"],input[type="submit"]{border-color:rgba(34,34,34,.1)}#comments{border-color:#292929}#comments{border-color:rgba(41,41,41,.1)}.comment-list:after{background-color:#191919}.comment-list:after{background-color:rgba(25,25,25,.1)}.site-title a{color:#eee}body{background-color:#000}.wp-caption{background-color:#000}#infinite-footer .container{background-color:#000}.hentry,.widget,.navigation-main ul ul li a,article.comment{background-color:#070707}.site-header,.page-links a span.active-link,.page-links span.active-link{background-color:#191919}.page-header,.site-footer,.content-area [class*="navigation"]{border-color:#000}.page-header,.site-footer,.content-area [class*="navigation"]{border-color:rgba(0,0,0,.2)}.site-footer,.navigation-main li a:hover,.navigation-main ul ul,.navigation-main li a:hover{background-color:#000}.navigation-main li a:hover{border-color:#000}.navigation-main li a:hover{border-color:rgba(0,0,0,.2)}button,html input[type="button"],input[type="reset"],input[type="submit"]{background-color:#000}button:hover,html input[type="button"]:hover,input[type="reset"]:hover,input[type="submit"]:hover{background-color:#000}a{color:#0084c1}a:visited{color:#0084c1}.site-title a:hover{color:#0084c1}.navigation-main li a:hover{color:#0084c1}.menu-toggle:hover{color:#0084c1}footer.entry-meta .post-link a:hover{color:#0084c1}footer.entry-meta a:hover{color:#0084c1}[class*="navigation"] a:hover{color:#0084c1}#comments a:hover{color:#0084c1}#flickr_badge_uber_wrapper a:hover,#flickr_badge_uber_wrapper a:link,#flickr_badge_uber_wrapper a:active,#flickr_badge_uber_wrapper a:visited{color:#0084c1}#infinite-footer .blog-credits,#infinite-footer .blog-credits a,#infinite-footer .blog-credits a:hover,#infinite-footer .blog-info a,#infinite-footer .blog-info a:hover{color:#0084c1}#infinite-handle span{background-color:#053c56}button,html input[type="button"],input[type="reset"],input[type="submit"]{color:#fff}a:hover,a:focus,a:active{color:#fff}.masonry .entry-title a{color:#fff}.masonry footer.entry-meta a:hover{color:#fff}</style>
<link rel="icon" href="https://i0.wp.com/battingwithbimal.com/wp-content/uploads/2020/01/cropped-Q6xV_jxh.jpg?fit=32%2C32&#038;ssl=1" sizes="32x32" />
<link rel="icon" href="https://i0.wp.com/battingwithbimal.com/wp-content/uploads/2020/01/cropped-Q6xV_jxh.jpg?fit=192%2C192&#038;ssl=1" sizes="192x192" />
<link rel="apple-touch-icon" href="https://i0.wp.com/battingwithbimal.com/wp-content/uploads/2020/01/cropped-Q6xV_jxh.jpg?fit=180%2C180&#038;ssl=1" />
<meta name="msapplication-TileImage" content="https://i0.wp.com/battingwithbimal.com/wp-content/uploads/2020/01/cropped-Q6xV_jxh.jpg?fit=270%2C270&#038;ssl=1" />
<style type="text/css" id="wp-custom-css">.site-description{
	color: whitesmoke !important;
}</style>		<!-- Jetpack Google Analytics -->
		<script async src='https://www.googletagmanager.com/gtag/js?id=G-GV521V1E8M'></script>
		<script>
			window.dataLayer = window.dataLayer || [];
			function gtag() { dataLayer.push( arguments ); }
			gtag( 'js', new Date() );
			gtag( 'config', "G-GV521V1E8M" );
					</script>
		<!-- End Jetpack Google Analytics -->
		</head>

<body class="post-template-default single single-post postid-159158 single-format-standard custom-background visual custom-colors">
<div id="page" class="hfeed site">
		<header id="masthead" class="site-header" role="banner">
		<div class="section clear">
						<div class="site-branding">
				<h1 class="site-title"><a href="https://battingwithbimal.com/" title="Batting with Bimal" rel="home">Batting with Bimal</a></h1>
				<h2 class="site-description">Pakistan cricket news, views and highlights</h2>
			</div>

			<nav id="site-navigation" class="navigation-main" role="navigation">
				<h1 class="menu-toggle">Menu</h1>
				<div class="screen-reader-text skip-link"><a href="#content" title="Skip to content">Skip to content</a></div>

				<div class="menu-batting-with-bimal-container"><ul id="menu-batting-with-bimal" class="menu"><li id="menu-item-16260" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-16260"><a href="https://battingwithbimal.com/future-pakistan-cricket-matches-and-series/">Future Pakistan Cricket Matches and Series</a></li>
<li id="menu-item-16258" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-16258"><a href="https://battingwithbimal.com/icc-cricket-team-and-player-rankings/">ICC Cricket Team and Player Rankings</a></li>
<li id="menu-item-39241" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-39241"><a href="https://battingwithbimal.com/exclusive-interviews/">Exclusive Interviews</a></li>
<li id="menu-item-53514" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-53514"><a href="https://battingwithbimal.com/category/features/">Features</a></li>
<li id="menu-item-39842" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-39842"><a href="https://battingwithbimal.com/cricketer-columns/">Cricketer Columns</a>
<ul class="sub-menu">
	<li id="menu-item-41066" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-41066"><a href="https://battingwithbimal.com/category/voices-zimbabwe-cricket/">Voices of Zimbabwe</a>
	<ul class="sub-menu">
		<li id="menu-item-41065" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-41065"><a href="https://battingwithbimal.com/who-is-peter-moor/">Who is Peter Moor?</a></li>
	</ul>
</li>
	<li id="menu-item-39924" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-39924"><a href="https://battingwithbimal.com/category/voices-of-oman/">Voices of Oman</a></li>
	<li id="menu-item-39845" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-39845"><a href="https://battingwithbimal.com/category/through-irish-eyes/">Through Irish Eyes</a>
	<ul class="sub-menu">
		<li id="menu-item-39860" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-39860"><a href="https://battingwithbimal.com/who-is-andy-balbirnie/">Who is Andy Balbirnie</a></li>
	</ul>
</li>
	<li id="menu-item-16266" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-16266"><a href="https://battingwithbimal.com/category/from-the-mind-of-myburgh/">From the mind of Myburgh</a>
	<ul class="sub-menu">
		<li id="menu-item-16273" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-16273"><a href="https://battingwithbimal.com/who-is-stephan-myburgh/">Who is Stephan Myburgh?</a></li>
	</ul>
</li>
</ul>
</li>
<li id="menu-item-35716" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-35716"><a href="https://battingwithbimal.com/personal-work/">Personal Work</a>
<ul class="sub-menu">
	<li id="menu-item-71092" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-71092"><a href="https://battingwithbimal.com/photos-2017-kgv-alumni-match/">Photos of the 2017 KGV Alumni Match</a></li>
	<li id="menu-item-51534" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-51534"><a href="https://battingwithbimal.com/dtc-hong-kong-t20-blitz-2017/">DTC Hong Kong T20 Blitz 2017</a>
	<ul class="sub-menu">
		<li id="menu-item-51551" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-51551"><a href="https://battingwithbimal.com/hong-kong-island-united/">Hong Kong Island United</a>
		<ul class="sub-menu">
			<li id="menu-item-51552" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-51552"><a href="https://battingwithbimal.com/meet-our-team/">Meet our Team</a></li>
			<li id="menu-item-51550" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-51550"><a href="https://battingwithbimal.com/photos-2/">Photos</a></li>
			<li id="menu-item-51549" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-51549"><a href="https://battingwithbimal.com/videos-2/">Videos</a></li>
		</ul>
</li>
		<li id="menu-item-52484" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-52484"><a href="https://battingwithbimal.com/dtc-hong-kong-t20-blitz-2017-match-reports/">DTC Hong Kong T20 Blitz 2017 Match Reports</a></li>
		<li id="menu-item-51548" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-51548"><a href="https://battingwithbimal.com/dtc-hong-kong-t20-blitz-2017-photos/">DTC Hong Kong T20 Blitz 2017 Photos</a></li>
	</ul>
</li>
	<li id="menu-item-38967" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-38967"><a href="https://battingwithbimal.com/dtc-hong-kong-t20-blitz/">DTC Hong Kong T20 Blitz</a>
	<ul class="sub-menu">
		<li id="menu-item-39207" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-39207"><a href="https://battingwithbimal.com/dtc-hong-kong-t20-blitz-match-reports/">DTC Hong Kong T20 Blitz Match Reports</a></li>
		<li id="menu-item-39195" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-39195"><a href="https://battingwithbimal.com/dtc-hong-kong-t20-blitz-photos/">DTC Hong Kong T20 Blitz Photos</a></li>
		<li id="menu-item-38966" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38966"><a href="https://battingwithbimal.com/dtc-hong-kong-t20-blitz-squads/">DTC Hong Kong T20 Blitz squads</a></li>
		<li id="menu-item-38994" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-38994"><a href="https://battingwithbimal.com/woodworm-warriors/">Woodworm Warriors</a>
		<ul class="sub-menu">
			<li id="menu-item-38993" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38993"><a href="https://battingwithbimal.com/match-reports/">Match Reports</a></li>
			<li id="menu-item-38992" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38992"><a href="https://battingwithbimal.com/photos/">Photos</a></li>
			<li id="menu-item-38995" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38995"><a href="https://battingwithbimal.com/videos/">Videos</a></li>
		</ul>
</li>
	</ul>
</li>
	<li id="menu-item-35906" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-35906"><a href="https://battingwithbimal.com/braidwood-cup-series/">Braidwood Cup Series</a>
	<ul class="sub-menu">
		<li id="menu-item-36089" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-36089"><a href="https://battingwithbimal.com/braidwood-cup-series-exclusive-content/">Braidwood Cup Series Exclusive Content</a></li>
		<li id="menu-item-36912" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-36912"><a href="https://battingwithbimal.com/braidwood-cup-series-2nd-t20/">Braidwood Cup Series 2nd T20</a>
		<ul class="sub-menu">
			<li id="menu-item-36911" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-36911"><a href="https://battingwithbimal.com/braidwood-cup-series-2nd-t20-photos/">Braidwood Cup Series 2nd T20 Photos</a></li>
		</ul>
</li>
		<li id="menu-item-36728" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-36728"><a href="https://battingwithbimal.com/braidwood-cup-series-1st-t20/">Braidwood Cup Series 1st T20</a>
		<ul class="sub-menu">
			<li id="menu-item-36727" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-36727"><a href="https://battingwithbimal.com/braidwood-cup-series-1st-t20-photos/">Braidwood Cup Series 1st T20 Photos</a></li>
			<li id="menu-item-36726" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-36726"><a href="https://battingwithbimal.com/braidwood-cup-series-1st-t20-videos/">Braidwood Cup Series 1st T20 Videos</a></li>
		</ul>
</li>
		<li id="menu-item-36528" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-36528"><a href="https://battingwithbimal.com/braidwood-cup-series-2nd-odi/">Braidwood Cup Series 2nd ODI</a>
		<ul class="sub-menu">
			<li id="menu-item-36527" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-36527"><a href="https://battingwithbimal.com/braidwood-cup-series-2nd-odi-photos/">Braidwood Cup Series 2nd ODI Photos</a></li>
		</ul>
</li>
		<li id="menu-item-36484" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-36484"><a href="https://battingwithbimal.com/braidwood-cup-series-1st-odi/">Braidwood Cup Series 1st ODI</a>
		<ul class="sub-menu">
			<li id="menu-item-36483" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-36483"><a href="https://battingwithbimal.com/braidwood-cup-series-1st-odi-photos/">Braidwood Cup Series 1st ODI Photos</a></li>
			<li id="menu-item-36482" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-36482"><a href="https://battingwithbimal.com/braidwood-cup-series-1st-odi-videos/">Braidwood Cup Series 1st ODI Videos</a></li>
		</ul>
</li>
		<li id="menu-item-36272" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-36272"><a href="https://battingwithbimal.com/braidwood-cup-series-day-4/">Braidwood Cup Series Day 4</a></li>
		<li id="menu-item-36228" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-36228"><a href="https://battingwithbimal.com/braidwood-cup-series-day-3/">Braidwood Cup Series Day 3</a>
		<ul class="sub-menu">
			<li id="menu-item-36356" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-36356"><a href="https://battingwithbimal.com/braidwood-cup-series-day-3-photos-2/">Braidwood Cup Series Day 3 Photos</a></li>
		</ul>
</li>
		<li id="menu-item-36161" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-36161"><a href="https://battingwithbimal.com/braidwood-cup-series-day-2/">Braidwood Cup Series Day 2</a>
		<ul class="sub-menu">
			<li id="menu-item-36355" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-36355"><a href="https://battingwithbimal.com/braidwood-cup-series-day-2-photos-2/">Braidwood Cup Series Day 2 Photos</a></li>
		</ul>
</li>
		<li id="menu-item-36084" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-36084"><a href="https://battingwithbimal.com/braidwood-cup-series-day-1-report/">Braidwood Cup Series Day 1</a>
		<ul class="sub-menu">
			<li id="menu-item-36354" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-36354"><a href="https://battingwithbimal.com/braidwood-cup-series-day-1-photos-2/">Braidwood Cup Series Day 1 Photos</a></li>
			<li id="menu-item-36088" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-36088"><a href="https://battingwithbimal.com/braidwood-cup-series-day-1-videos/">Braidwood Cup Series Day 1 Videos</a></li>
		</ul>
</li>
		<li id="menu-item-35945" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-35945"><a href="https://battingwithbimal.com/braidwood-cup-series-pre-series-press-conference/">Braidwood Cup Series: Pre-series press conference</a></li>
	</ul>
</li>
	<li id="menu-item-31087" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-31087"><a href="https://battingwithbimal.com/sixes4nepal-2/">#Sixes4Nepal</a>
	<ul class="sub-menu">
		<li id="menu-item-31245" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-31245"><a href="https://battingwithbimal.com/sixes4nepal-day-2/">#Sixes4Nepal Day 2</a></li>
		<li id="menu-item-31235" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-31235"><a href="https://battingwithbimal.com/sixes4nepal-day-1/">#Sixes4Nepal Day 1</a></li>
		<li id="menu-item-31138" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-31138"><a href="https://battingwithbimal.com/sixes4nepal-team-list/">#SIXES4NEPAL TEAM LIST</a></li>
		<li id="menu-item-31096" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-31096"><a href="https://battingwithbimal.com/sixes4nepal-interviews/">#Sixes4Nepal Interviews</a></li>
		<li id="menu-item-31093" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-31093"><a href="https://battingwithbimal.com/sixes4nepal-photos/">#Sixes4Nepal Photos</a></li>
	</ul>
</li>
	<li id="menu-item-32898" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-32898"><a href="https://battingwithbimal.com/east-asia-mens-tournament/">East Asia Men’s Tournament</a>
	<ul class="sub-menu">
		<li id="menu-item-33004" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-33004"><a href="https://battingwithbimal.com/east-asia-mens-tournament-photos/">East Asia Men’s Tournament Photos</a></li>
	</ul>
</li>
	<li id="menu-item-33672" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-33672"><a href="https://battingwithbimal.com/on-tour-with-chris-carter/">On tour with Hong Kong’s Chris Carter</a>
	<ul class="sub-menu">
		<li id="menu-item-33675" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-33675"><a href="https://battingwithbimal.com/about-chris-carter/">About Chris Carter</a></li>
	</ul>
</li>
</ul>
</li>
<li id="menu-item-41180" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-41180"><a href="https://battingwithbimal.com/features-for-other-publications/">Features for other publications</a></li>
<li id="menu-item-16261" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-16261"><a href="https://battingwithbimal.com/about/">About</a></li>
<li id="menu-item-16259" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-16259"><a href="https://battingwithbimal.com/contact-me/">Contact Me</a></li>
<li class=" astm-search-menu is-menu is-dropdown menu-item"><a href="#" aria-label="Search Icon Link"><svg width="20" height="20" class="search-icon" role="img" viewBox="2 9 20 5" focusable="false" aria-label="Search">
						<path class="search-icon-path" d="M15.5 14h-.79l-.28-.27C15.41 12.59 16 11.11 16 9.5 16 5.91 13.09 3 9.5 3S3 5.91 3 9.5 5.91 16 9.5 16c1.61 0 3.09-.59 4.23-1.57l.27.28v.79l5 4.99L20.49 19l-4.99-5zm-6 0C7.01 14 5 11.99 5 9.5S7.01 5 9.5 5 14 7.01 14 9.5 11.99 14 9.5 14z"></path></svg></a><form  class="is-search-form is-form-style is-form-style-3 is-form-id-0 " action="https://battingwithbimal.com/" method="get" role="search" ><label for="is-search-input-0"><span class="is-screen-reader-text">Search for:</span><input  type="search" id="is-search-input-0" name="s" value="" class="is-search-input" placeholder="Search here..." autocomplete=off /></label><button type="submit" class="is-search-submit"><span class="is-screen-reader-text">Search Button</span><span class="is-search-icon"><svg focusable="false" aria-label="Search" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 24 24" width="24px"><path d="M15.5 14h-.79l-.28-.27C15.41 12.59 16 11.11 16 9.5 16 5.91 13.09 3 9.5 3S3 5.91 3 9.5 5.91 16 9.5 16c1.61 0 3.09-.59 4.23-1.57l.27.28v.79l5 4.99L20.49 19l-4.99-5zm-6 0C7.01 14 5 11.99 5 9.5S7.01 5 9.5 5 14 7.01 14 9.5 11.99 14 9.5 14z"></path></svg></span></button></form><div class="search-close"></div></li></ul></div>			</nav><!-- #site-navigation -->
		</div>
	</header><!-- #masthead -->

	<div id="main" class="site-main">

	<div id="primary" class="content-area">
		<div id="content" class="site-content" role="main">

		
			
<article id="post-159158" class="post-159158 post type-post status-publish format-standard hentry category-uncategorized tag-100-percent tag-australia-vs-pakistan tag-gives-his-best tag-hasan-ali tag-lancashire tag-match-winner tag-middlesex tag-pak-cricket tag-pak-cricket-news tag-pak-vs-aus tag-pakistan tag-pakistan-cricket tag-pakistan-cricket-news tag-pakistan-vs-australia tag-shaheen-shah-afridi">
	<header class="entry-header">
		<h1 class="entry-title">We all know he&#8217;s a match-winner, Shaheen Shah Afridi on Pakistan player who always gives 100 percent</h1>

		<div class="entry-meta">
						Posted on <a href="https://battingwithbimal.com/2022/05/19/we-all-know-hes-a-match-winner-shaheen-shah-afridi-on-pakistan-player-who-always-gives-100-percent/" title="6:13 AM" rel="bookmark"><time class="entry-date" datetime="2022-05-19T06:13:20+08:00">May 19, 2022</time></a><span class="byline"> by <span class="author vcard"><a class="url fn n" href="https://battingwithbimal.com/author/bimalmirwani/" title="View all posts by bimalmirwani" rel="author">bimalmirwani</a></span></span>		</div><!-- .entry-meta -->
	</header><!-- .entry-header -->

	<div class="entry-content">
		<div id="attachment_124328" style="width: 1410px" class="wp-caption alignnone"><a href="https://i0.wp.com/battingwithbimal.com/wp-content/uploads/2020/09/297368.jpg?ssl=1"><img aria-describedby="caption-attachment-124328" data-attachment-id="124328" data-permalink="https://battingwithbimal.com/2020/09/24/shaheen-shah-afridi-makes-honest-admission-about-upcoming-pakistan-domestic-season/australia-v-pakistan-2nd-test-day-1-9/#main" data-orig-file="https://i0.wp.com/battingwithbimal.com/wp-content/uploads/2020/09/297368.jpg?fit=1400%2C2100&amp;ssl=1" data-orig-size="1400,2100" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;4&quot;,&quot;credit&quot;:&quot;Getty Images&quot;,&quot;camera&quot;:&quot;Canon EOS-1D X Mark II&quot;,&quot;caption&quot;:&quot;ADELAIDE, AUSTRALIA - NOVEMBER 29: Shaheen Shah Afridi of Pakistan celebrates taking the wicket of Joe Burns of Australia during day one of the 2nd Domain Test between Australia and Pakistan at Adelaide Oval on November 29, 2019 in Adelaide, Australia. (Photo by Mark Kolbe\/Getty Images)&quot;,&quot;created_timestamp&quot;:&quot;1575041125&quot;,&quot;copyright&quot;:&quot;2019 Getty Images&quot;,&quot;focal_length&quot;:&quot;600&quot;,&quot;iso&quot;:&quot;640&quot;,&quot;shutter_speed&quot;:&quot;0.0004&quot;,&quot;title&quot;:&quot;Australia v Pakistan - 2nd Test: Day 1&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="" data-image-description="" data-image-caption="&lt;p&gt;Shaheen Shah Afridi: &#8220;He has given his best, we all know that he is a match-winner for our side&#8221;&lt;/p&gt;
" data-medium-file="https://i0.wp.com/battingwithbimal.com/wp-content/uploads/2020/09/297368.jpg?fit=200%2C300&amp;ssl=1" data-large-file="https://i0.wp.com/battingwithbimal.com/wp-content/uploads/2020/09/297368.jpg?fit=670%2C1005&amp;ssl=1" class="size-full wp-image-124328" src="https://i0.wp.com/battingwithbimal.com/wp-content/uploads/2020/09/297368.jpg?resize=670%2C1005&#038;ssl=1" alt="Shaheen Shah Afridi said we all know Pakistan fast bowler Hasan Ali is a match-winner" width="670" height="1005" srcset="https://i0.wp.com/battingwithbimal.com/wp-content/uploads/2020/09/297368.jpg?w=1400&amp;ssl=1 1400w, https://i0.wp.com/battingwithbimal.com/wp-content/uploads/2020/09/297368.jpg?resize=200%2C300&amp;ssl=1 200w, https://i0.wp.com/battingwithbimal.com/wp-content/uploads/2020/09/297368.jpg?resize=683%2C1024&amp;ssl=1 683w, https://i0.wp.com/battingwithbimal.com/wp-content/uploads/2020/09/297368.jpg?resize=768%2C1152&amp;ssl=1 768w, https://i0.wp.com/battingwithbimal.com/wp-content/uploads/2020/09/297368.jpg?resize=1024%2C1536&amp;ssl=1 1024w, https://i0.wp.com/battingwithbimal.com/wp-content/uploads/2020/09/297368.jpg?resize=1365%2C2048&amp;ssl=1 1365w, https://i0.wp.com/battingwithbimal.com/wp-content/uploads/2020/09/297368.jpg?resize=1200%2C1800&amp;ssl=1 1200w, https://i0.wp.com/battingwithbimal.com/wp-content/uploads/2020/09/297368.jpg?resize=480%2C720&amp;ssl=1 480w" sizes="(max-width: 670px) 100vw, 670px" data-recalc-dims="1" /></a><p id="caption-attachment-124328" class="wp-caption-text">Shaheen Shah Afridi: &#8220;He has given his best, we all know that he is a match-winner for our side&#8221;</p></div>
<p>Image courtesy of: ESPNcricinfo</p>
<p>Pakistan left-arm fast bowler Shaheen Shah Afridi said Hasan Ali is a &#8220;match-winner&#8221; and always gives 100 percent when out on the field.</p>
<p><span id="more-159158"></span></p>
<p>His praise comes after Hasan struggled to have a major impact in Pakistan&#8217;s historic home series against Australia.</p>
<p>Hasan was restricted to two wickets in two Tests at an average of 96 before going wicketless in the limited overs games he featured in.</p>
<p>However, the 27-year-old is rediscovering his form in the County Championship as he has picked up 24 wickets in four matches for Lancashire at an average of 18.50.</p>
<p>&#8220;He has given his best, we all know that he is a match-winner for our side,&#8221; Afridi was quoted as saying by <em><a href="https://cricwick.net/news/12782/Shaheen-Afridi-If-you-bowl-in-the-right-areas-you-can-get-wickets" target="_blank" rel="noopener">Cricwick</a></em>.</p>
<p>Afridi was also in action on the county circuit recently as he snapped up 14 wickets in three games for Middlesex at an average of 25.42.</p>
<p><a href="https://battingwithbimal.com/2022/05/19/his-bowling-has-been-brilliant-shaheen-shah-afridi-on-pakistan-bowler-getting-back-to-his-best/" target="_blank" rel="noopener"><em><strong>ALSO CHECK OUT: His bowling has been brilliant, Shaheen Shah Afridi on Pakistan bowler getting back to his best</strong></em></a></p>
<style type="text/css" id="tsp_form_styles_488693">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</style>
			<form method='POST' class='ts_poll_form_488693' data-tsp-pos='center'>
				<section class='ts_poll_section_488693' data-tsp-box='false'>
					<div class='ts_poll_loading'><img class='ts_poll_loading_img' src='https://i0.wp.com/battingwithbimal.com/wp-content/plugins/poll-wp/public/img/tsp_loading.gif?w=670&#038;ssl=1' data-recalc-dims="1"></div>
				<style type="text/css" id="tsp_header_styles_488693">
    :root{
        /* Root for header */
        --tsp_header_bgc_488693:#000000;
        --tsp_header_c_488693:#ffffff;
        --tsp_header_fs_488693:23px;
        --tsp_header_ff_488693:Gabriola;
        --tsp_header_ta_488693:center;
        /* Root for header line*/
        --tsp_header_l_w_488693:80%;
        --tsp_header_l_bh_488693:0px;
        --tsp_header_l_bs_488693:solid;
        --tsp_header_l_bc_488693:#1e73be;
    }

    /* Header CSS */
    header.ts_poll_header_488693{
        width:100%;
        display: -ms-flexbox;display: -webkit-flex;display: flex;
        -webkit-flex-direction: column;-ms-flex-direction: column;flex-direction: column;
        -webkit-flex-wrap: nowrap;-ms-flex-wrap: nowrap;flex-wrap: nowrap;
        -webkit-justify-content: center;-ms-flex-pack: center;justify-content: center;
        -webkit-align-content: center;-ms-flex-line-pack: center;align-content: center;
        -webkit-align-items: center;-ms-flex-align: center;align-items: center;
        -webkit-justify-content: center;-ms-flex-pack: center;justify-content: center;
        background-color:var(--tsp_header_bgc_488693); 
        color:var(--tsp_header_c_488693); 
        padding: 5px 10px 5px;
    }
    header.ts_poll_header_488693 > span.ts_poll_title_488693{
        margin-bottom: 7px;
        font-family:var(--tsp_header_ff_488693);
        line-height:var(--tsp_header_fs_488693);
        font-size:var(--tsp_header_fs_488693);
        text-align:var(--tsp_header_ta_488693);
        word-break: break-all;
    }
    header.ts_poll_header_488693[data-tsp-pos="left"] > span.ts_poll_title_488693{
        margin-right: auto;
    }
    header.ts_poll_header_488693[data-tsp-pos="right"] > span.ts_poll_title_488693{
        margin-left: auto;
    }
    header.ts_poll_header_488693 > div.ts_poll_line_488693{
        width:var(--tsp_header_l_w_488693);
        border-top-width:var(--tsp_header_l_bh_488693);
        border-top-style:var(--tsp_header_l_bs_488693);
        border-top-color:var(--tsp_header_l_bc_488693);
    }
 

</style>

        <header class='ts_poll_header_488693' data-tsp-pos='center'>
            
            <span class='ts_poll_title_488693'>
                What are your thoughts on Hasan Ali?
            </span>
            <div class='ts_poll_line_488693'></div>
        </header><style type="text/css" id="tsp_styles_488693">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</style>

      <main class='ts_poll_main_488693' data-tsp-bool='true'>
        
      <div class='ts_poll_answer' data-tsp-id='213'>
        <input  type='radio' 
                class='ts_poll_answer_input'
                id='ts_poll_answer_input_488693-1'
                name='ts_poll_all488693'
                value='213'
                style='display:none;'>
        <label  class='ts_poll_answer_label' 
                for='ts_poll_answer_input_488693-1'>
          <span>He is really good!</span>
        </label>
      </div>
      
      <div class='ts_poll_answer' data-tsp-id='214'>
        <input  type='radio' 
                class='ts_poll_answer_input'
                id='ts_poll_answer_input_488693-2'
                name='ts_poll_all488693'
                value='214'
                style='display:none;'>
        <label  class='ts_poll_answer_label' 
                for='ts_poll_answer_input_488693-2'>
          <span>He is ok!</span>
        </label>
      </div>
      
      <div class='ts_poll_answer' data-tsp-id='215'>
        <input  type='radio' 
                class='ts_poll_answer_input'
                id='ts_poll_answer_input_488693-3'
                name='ts_poll_all488693'
                value='215'
                style='display:none;'>
        <label  class='ts_poll_answer_label' 
                for='ts_poll_answer_input_488693-3'>
          <span>He is overrated!</span>
        </label>
      </div>
      
        <div class='ts_poll_after_line_488693'></div>
      </main>
      
        <footer class='ts_poll_footer_488693'>
            <button class='ts_poll_result_button'
                         id='ts_poll_result_button_488693'
                         style=''
                         name='ts_poll_result_button' type='button'
                         data-tsp-pos='left'
                         data-tsp-text='Results'>
                  <i class='ts_poll_result_icon ts-poll ts-poll-info-circle' data-tsp='after'><span data-tsp-text='Results'></span></i>
                </button>
            <button class='ts_poll_vote_button'
                         id='ts_poll_vote_button'
                         name='ts_poll_vote_button' type='button'
                         data-tsp-text='Vote'
                         data-tsp-pos='right'>
                  <i class='ts_poll_vote_icon ts-poll ts-poll-paper-plane' data-tsp='before'><span data-tsp-text='Vote'></span></i>
                </button>
        </footer>    
        
      
        <div class='ts_poll_r_section_488693'
             data-tsp-effect='FTTB' 
             data-tsp-pos='center'
             data-tsp-bool='true'>
            <header class='ts_poll_r_header_488693' data-tsp-pos='center'>
                <span class='ts_poll_title_488693'>
                    What are your thoughts on Hasan Ali?
                </span>
                <div class='ts_poll_line_488693'></div>
            </header>
            <main class='ts_poll_r_main_488693' 
                  data-tsp-after='' 
                  data-tsp-bool='true'
                  data-tsp-veff='1'>
                
        <div class='ts_poll_answer_result' data-tsp-id='213' >
            <label class='ts_poll_answer_result_label'>
                <span class='ts_poll_r_answer_title'>
                    He is really good!
                </span>
                <span class='ts_poll_answer_percent_line Total_Soft_Poll_1_Ans_Lab_Sp2_488693_213'
                    data-tsp-w='0%'
                    style=''>
                </span>
                <span data-tsp-vt='both' class='ts_poll_answer_info_line Total_Soft_Poll_1_Ans_Lab_Sp3_488693_213'>
                    0 ( 0 % )
                </span>
            </label>
        </div>
        
        <div class='ts_poll_answer_result' data-tsp-id='214' >
            <label class='ts_poll_answer_result_label'>
                <span class='ts_poll_r_answer_title'>
                    He is ok!
                </span>
                <span class='ts_poll_answer_percent_line Total_Soft_Poll_1_Ans_Lab_Sp2_488693_214'
                    data-tsp-w='0%'
                    style=''>
                </span>
                <span data-tsp-vt='both' class='ts_poll_answer_info_line Total_Soft_Poll_1_Ans_Lab_Sp3_488693_214'>
                    0 ( 0 % )
                </span>
            </label>
        </div>
        
        <div class='ts_poll_answer_result' data-tsp-id='215' >
            <label class='ts_poll_answer_result_label'>
                <span class='ts_poll_r_answer_title'>
                    He is overrated!
                </span>
                <span class='ts_poll_answer_percent_line Total_Soft_Poll_1_Ans_Lab_Sp2_488693_215'
                    data-tsp-w='0%'
                    style=''>
                </span>
                <span data-tsp-vt='both' class='ts_poll_answer_info_line Total_Soft_Poll_1_Ans_Lab_Sp3_488693_215'>
                    0 ( 0 % )
                </span>
            </label>
        </div>
        
                <div class='ts_poll_after_line_488693'></div>
            </main>
            <footer class='ts_poll_r_footer_488693'
                     style=''
                     data-tsp-pos='full'>
                <button class='ts_poll_back_button Total_Soft_Poll_1_But_Back_488693' 
                        id='ts_poll_back_button_488693' 
                        name='ts_poll_back_button_488693' type='button' 
                        data-tsp-text='Back' 
                        >
                    <i class='ts-poll ts_poll_back_icon ts-poll ts-poll-refresh Total_Soft_Poll_1_Back_But_Icon' data-tsp='before'><span data-tsp-text='Back'></span></i>
                </button>
            </footer>
        </div>    
        
      
        <script>
            function tsp_show_results_488693(){
              
              
                jQuery(".ts_poll_r_section_488693").css({
                    "transform": "translateY(0px)",
                    "-ms-transform": "translateY(0px)",
                    "-o-transform": "translateY(0px)",
                    "-moz-transform": "translateY(0px)",
                    "-webkit-transform": "translateY(0px)",
                    "opacity": "1"
                });
            
        setTimeout(() => {
          jQuery(".ts_poll_header_488693,.ts_poll_main_488693,.ts_poll_footer_488693").css({
            "opacity": "0"
          });
        }, 500);
        
              
          jQuery(".ts_poll_r_main_488693 >  .ts_poll_answer_result > .ts_poll_answer_result_label > span.ts_poll_answer_percent_line").each(function () {
              jQuery(this).animate({"width": jQuery(this).attr("data-tsp-w")}, 1500);
          });
      
            }
            jQuery(document).on("click", "button#ts_poll_result_button_488693", tsp_show_results_488693);
            jQuery(document).on("click", "button#ts_poll_back_button_488693", function() {
              
              jQuery("section.ts_poll_section_488693 .ts_poll_r_section_488693").css({
                "transform": "translateY(-12000px)",
                "-ms-transform": "translateY(-12000px)",
                "-o-transform": "translateY(-12000px)",
                "-moz-transform": "translateY(-12000px)",
                "-webkit-transform": "translateY(-12000px)",
                "opacity": "0"
              });
            
            jQuery(".ts_poll_header_488693,.ts_poll_main_488693,.ts_poll_footer_488693").css({
                "opacity": "1"
            });
        
            });
            
        function tsp_change_results_488693(tsp_results_arr){
          jQuery("main.ts_poll_r_main_488693 > div.ts_poll_answer_result").each(function () {
            jQuery(this).find("span.ts_poll_answer_percent_line").attr("data-tsp-w",tsp_results_arr[`${jQuery(this).attr("data-tsp-id")}`]["tsp_result_percent"] + "%");
            jQuery(this).find("span.ts_poll_answer_info_line").html(tsp_results_arr[`${jQuery(this).attr("data-tsp-id")}`]["tsp_result_show"]);
          });
        }
        </script>
      <style type="text/css" id="tsp_global_styles_488693">
    .tsp_flex_col {
        display: -ms-flexbox;
        display: -webkit-flex;
        display: flex;
        -webkit-flex-direction: column;
        -ms-flex-direction: column;
        flex-direction: column;
        -webkit-flex-wrap: nowrap;
        -ms-flex-wrap: nowrap;
        flex-wrap: nowrap;
        -webkit-justify-content: center;
        -ms-flex-pack: center;
        justify-content: center;
        -webkit-align-content: center;
        -ms-flex-line-pack: center;
        align-content: center;
        -webkit-align-items: center;
        -ms-flex-align: center;
        align-items: center;
    }
    .tsp_flex_row {
        display: -ms-flexbox;
        display: -webkit-flex;
        display: flex;
        -webkit-flex-direction: row;
        -ms-flex-direction: row;
        flex-direction: row;
        -webkit-flex-wrap: nowrap;
        -ms-flex-wrap: nowrap;
        flex-wrap: nowrap;
        -webkit-justify-content: center;
        -ms-flex-pack: center;
        justify-content: center;
        -webkit-align-content: center;
        -ms-flex-line-pack: center;
        align-content: center;
        -webkit-align-items: center;
        -ms-flex-align: center;
        align-items: center;
    }
    /* Main CSS */
    :root{
                   --tsp_before_check_c_488693:#dd9933;
           --tsp_after_check_c_488693:#dd9933;
           --tsp_before_check_488693:"\f10c";
           --tsp_after_check_488693:"\f192";
                --tsp_answer_fs_488693:17px;
        --tsp_main_bgc_488693:#000000;
        --tsp_answer_bgc_488693:#000000;
        --tsp_answer_h_bgc_488693:#000000;
        --tsp_answer_h_c_488693:#ffffff;
        --tsp_answer_c_488693:#dd9933;
        --tsp_answer_ff_488693:Arial;
    }
    footer.ts_poll_footer_488693 button:focus{
        outline: none !important;
    }

    form.ts_poll_form_488693[max-width~="500px"] section.ts_poll_section_488693{
        width: 100% !important;
    }
    
    section.ts_poll_section_488693[max-width~="400px"] footer.ts_poll_footer_488693 button {
        width: 98% !important;
        margin: 5px 1% !important;
    }

    /* After answers line CSS */
    :root{
        --tsp_main_l_bw_488693:80%;
        --tsp_main_l_bh_488693:1px;
        --tsp_main_l_bc_488693:#dd9933;
        --tsp_main_l_bs_488693:solid;
    }
    main.ts_poll_main_488693 >  div.ts_poll_after_line_488693 {
        width: var(--tsp_main_l_bw_488693);
        margin-top: 5px;
        border-top: var(--tsp_main_l_bh_488693) var(--tsp_main_l_bs_488693) var(--tsp_main_l_bc_488693);
    }
	</style>
					
				<style  id='tsp_fontface_488693'>
				    
				</style>
		  		
				</section>
				<input type="hidden" id="tsp_vote_nonce_field_488693" name="tsp_vote_nonce_field_488693" value="2091515a85" /><input type="hidden" name="_wp_http_referer" value="/2022/05/19/we-all-know-hes-a-match-winner-shaheen-shah-afridi-on-pakistan-player-who-always-gives-100-percent/" />
			</form>
			
<div class='sharedaddy sd-block sd-like jetpack-likes-widget-wrapper jetpack-likes-widget-unloaded' id='like-post-wrapper-33086731-159158-62859fc6a4c47' data-src='https://widgets.wp.com/likes/#blog_id=33086731&amp;post_id=159158&amp;origin=battingwithbimal.com&amp;obj_id=33086731-159158-62859fc6a4c47' data-name='like-post-frame-33086731-159158-62859fc6a4c47' data-title='Like or Reblog'><h3 class="sd-title">Like this:</h3><div class='likes-widget-placeholder post-likes-widget-placeholder' style='height: 55px;'><span class='button'><span>Like</span></span> <span class="loading">Loading...</span></div><span class='sd-text-color'></span><a class='sd-link-color'></a></div>
<div id='jp-relatedposts' class='jp-relatedposts' >
	<h3 class="jp-relatedposts-headline"><em>Related</em></h3>
</div><div class='heateor_sss_sharing_container heateor_sss_vertical_sharing heateor_sss_bottom_sharing' style='width:44px;left: -10px;top: 325px;-webkit-box-shadow:none;box-shadow:none;' data-heateor-sss-href='https://battingwithbimal.com/2022/05/19/we-all-know-hes-a-match-winner-shaheen-shah-afridi-on-pakistan-player-who-always-gives-100-percent/'><div class="heateor_sss_sharing_ul"><a class="heateor_sss_facebook" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fbattingwithbimal.com%2F2022%2F05%2F19%2Fwe-all-know-hes-a-match-winner-shaheen-shah-afridi-on-pakistan-player-who-always-gives-100-percent%2F" title="Facebook" rel="nofollow noopener" target="_blank" style="font-size:32px!important;box-shadow:none;display:inline-block;vertical-align:middle"><span class="heateor_sss_svg" style="background-color:#3c589a;width:40px;height:40px;border-radius:999px;display:inline-block;opacity:1;float:left;font-size:32px;box-shadow:none;display:inline-block;font-size:16px;padding:0 4px;vertical-align:middle;background-repeat:repeat;overflow:hidden;padding:0;cursor:pointer;box-sizing:content-box"><svg style="display:block;border-radius:999px;" focusable="false" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="100%" height="100%" viewBox="-5 -5 42 42"><path d="M17.78 27.5V17.008h3.522l.527-4.09h-4.05v-2.61c0-1.182.33-1.99 2.023-1.99h2.166V4.66c-.375-.05-1.66-.16-3.155-.16-3.123 0-5.26 1.905-5.26 5.405v3.016h-3.53v4.09h3.53V27.5h4.223z" fill="#fff"></path></svg></span></a><a class="heateor_sss_button_twitter" href="http://twitter.com/intent/tweet?text=We%20all%20know%20he%27s%20a%20match-winner%2C%20Shaheen%20Shah%20Afridi%20on%20Pakistan%20player%20who%20always%20gives%20100%20percent&url=https%3A%2F%2Fbattingwithbimal.com%2F2022%2F05%2F19%2Fwe-all-know-hes-a-match-winner-shaheen-shah-afridi-on-pakistan-player-who-always-gives-100-percent%2F" title="Twitter" rel="nofollow noopener" target="_blank" style="font-size:32px!important;box-shadow:none;display:inline-block;vertical-align:middle"><span class="heateor_sss_svg heateor_sss_s__default heateor_sss_s_twitter" style="background-color:#55acee;width:40px;height:40px;border-radius:999px;display:inline-block;opacity:1;float:left;font-size:32px;box-shadow:none;display:inline-block;font-size:16px;padding:0 4px;vertical-align:middle;background-repeat:repeat;overflow:hidden;padding:0;cursor:pointer;box-sizing:content-box"><svg style="display:block;border-radius:999px;" focusable="false" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="100%" height="100%" viewBox="-4 -4 39 39"><path d="M28 8.557a9.913 9.913 0 0 1-2.828.775 4.93 4.93 0 0 0 2.166-2.725 9.738 9.738 0 0 1-3.13 1.194 4.92 4.92 0 0 0-3.593-1.55 4.924 4.924 0 0 0-4.794 6.049c-4.09-.21-7.72-2.17-10.15-5.15a4.942 4.942 0 0 0-.665 2.477c0 1.71.87 3.214 2.19 4.1a4.968 4.968 0 0 1-2.23-.616v.06c0 2.39 1.7 4.38 3.952 4.83-.414.115-.85.174-1.297.174-.318 0-.626-.03-.928-.086a4.935 4.935 0 0 0 4.6 3.42 9.893 9.893 0 0 1-6.114 2.107c-.398 0-.79-.023-1.175-.068a13.953 13.953 0 0 0 7.55 2.213c9.056 0 14.01-7.507 14.01-14.013 0-.213-.005-.426-.015-.637.96-.695 1.795-1.56 2.455-2.55z" fill="#fff"></path></svg></span></a><a class="heateor_sss_whatsapp" href="https://api.whatsapp.com/send?text=We%20all%20know%20he%27s%20a%20match-winner%2C%20Shaheen%20Shah%20Afridi%20on%20Pakistan%20player%20who%20always%20gives%20100%20percent https%3A%2F%2Fbattingwithbimal.com%2F2022%2F05%2F19%2Fwe-all-know-hes-a-match-winner-shaheen-shah-afridi-on-pakistan-player-who-always-gives-100-percent%2F" title="Whatsapp" rel="nofollow noopener" target="_blank" style="font-size:32px!important;box-shadow:none;display:inline-block;vertical-align:middle"><span class="heateor_sss_svg" style="background-color:#55eb4c;width:40px;height:40px;border-radius:999px;display:inline-block;opacity:1;float:left;font-size:32px;box-shadow:none;display:inline-block;font-size:16px;padding:0 4px;vertical-align:middle;background-repeat:repeat;overflow:hidden;padding:0;cursor:pointer;box-sizing:content-box"><svg style="display:block;border-radius:999px;" focusable="false" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="100%" height="100%" viewBox="-6 -5 40 40"><path class="heateor_sss_svg_stroke heateor_sss_no_fill" stroke="#fff" stroke-width="2" fill="none" d="M 11.579798566743314 24.396926207859085 A 10 10 0 1 0 6.808479557110079 20.73576436351046"></path><path d="M 7 19 l -1 6 l 6 -1" class="heateor_sss_no_fill heateor_sss_svg_stroke" stroke="#fff" stroke-width="2" fill="none"></path><path d="M 10 10 q -1 8 8 11 c 5 -1 0 -6 -1 -3 q -4 -3 -5 -5 c 4 -2 -1 -5 -1 -4" fill="#fff"></path></svg></span></a><a class="heateor_sss_button_facebook_messenger" style="font-size:32px!important;box-shadow:none;display:inline-block;vertical-align:middle"><span class="heateor_sss_svg heateor_sss_s__default heateor_sss_s_facebook_messenger" style="background-color:#0084ff;width:40px;height:40px;border-radius:999px;display:inline-block;opacity:1;float:left;font-size:32px;box-shadow:none;display:inline-block;font-size:16px;padding:0 4px;vertical-align:middle;background-repeat:repeat;overflow:hidden;padding:0;cursor:pointer;box-sizing:content-box" onclick='heateorSssPopup("https://www.facebook.com/dialog/send?app_id=1904103319867886&display=popup&link=https%3A%2F%2Fbattingwithbimal.com%2F2022%2F05%2F19%2Fwe-all-know-hes-a-match-winner-shaheen-shah-afridi-on-pakistan-player-who-always-gives-100-percent%2F&redirect_uri=https%3A%2F%2Fbattingwithbimal.com%2F2022%2F05%2F19%2Fwe-all-know-hes-a-match-winner-shaheen-shah-afridi-on-pakistan-player-who-always-gives-100-percent%2F")'><svg style="display:block;border-radius:999px;" focusable="false" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="100%" height="100%" viewBox="-2 -2 36 36"><path fill="#fff" d="M16 5C9.986 5 5.11 9.56 5.11 15.182c0 3.2 1.58 6.054 4.046 7.92V27l3.716-2.06c.99.276 2.04.425 3.128.425 6.014 0 10.89-4.56 10.89-10.183S22.013 5 16 5zm1.147 13.655L14.33 15.73l-5.423 3 5.946-6.31 2.816 2.925 5.42-3-5.946 6.31z"/></svg></span></a><a class="heateor_sss_button_linkedin" href="http://www.linkedin.com/shareArticle?mini=true&url=https%3A%2F%2Fbattingwithbimal.com%2F2022%2F05%2F19%2Fwe-all-know-hes-a-match-winner-shaheen-shah-afridi-on-pakistan-player-who-always-gives-100-percent%2F&title=We%20all%20know%20he%27s%20a%20match-winner%2C%20Shaheen%20Shah%20Afridi%20on%20Pakistan%20player%20who%20always%20gives%20100%20percent" title="Linkedin" rel="nofollow noopener" target="_blank" style="font-size:32px!important;box-shadow:none;display:inline-block;vertical-align:middle"><span class="heateor_sss_svg heateor_sss_s__default heateor_sss_s_linkedin" style="background-color:#0077b5;width:40px;height:40px;border-radius:999px;display:inline-block;opacity:1;float:left;font-size:32px;box-shadow:none;display:inline-block;font-size:16px;padding:0 4px;vertical-align:middle;background-repeat:repeat;overflow:hidden;padding:0;cursor:pointer;box-sizing:content-box"><svg style="display:block;border-radius:999px;" focusable="false" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="100%" height="100%" viewBox="0 0 32 32"><path d="M6.227 12.61h4.19v13.48h-4.19V12.61zm2.095-6.7a2.43 2.43 0 0 1 0 4.86c-1.344 0-2.428-1.09-2.428-2.43s1.084-2.43 2.428-2.43m4.72 6.7h4.02v1.84h.058c.56-1.058 1.927-2.176 3.965-2.176 4.238 0 5.02 2.792 5.02 6.42v7.395h-4.183v-6.56c0-1.564-.03-3.574-2.178-3.574-2.18 0-2.514 1.7-2.514 3.46v6.668h-4.187V12.61z" fill="#fff"></path></svg></span></a><a class="heateor_sss_more" title="More" rel="nofollow noopener" style="font-size: 32px!important;border:0;box-shadow:none;display:inline-block!important;font-size:16px;padding:0 4px;vertical-align: middle;display:inline;" href="https://battingwithbimal.com/2022/05/19/we-all-know-hes-a-match-winner-shaheen-shah-afridi-on-pakistan-player-who-always-gives-100-percent/" onclick="event.preventDefault()"><span class="heateor_sss_svg" style="background-color:#ee8e2d;width:40px;height:40px;border-radius:999px;display:inline-block!important;opacity:1;float:left;font-size:32px!important;box-shadow:none;display:inline-block;font-size:16px;padding:0 4px;vertical-align:middle;display:inline;background-repeat:repeat;overflow:hidden;padding:0;cursor:pointer;box-sizing:content-box;" onclick="heateorSssMoreSharingPopup(this, 'https://battingwithbimal.com/2022/05/19/we-all-know-hes-a-match-winner-shaheen-shah-afridi-on-pakistan-player-who-always-gives-100-percent/', 'We%20all%20know%20he%27s%20a%20match-winner%2C%20Shaheen%20Shah%20Afridi%20on%20Pakistan%20player%20who%20always%20gives%20100%20percent', '' )"><svg xmlns="http://www.w3.org/2000/svg" style="display:block;border-radius:999px;" width="100%" height="100%" viewBox="-4 -4 38 38"><circle cx="10" cy="15" r="3" fill="#fff"></circle><circle cx="20" cy="10" r="3" fill="#fff"></circle><circle cx="20" cy="20" r="3" fill="#fff"></circle><path d="M 10 15 L 20 10 m 0 10 L 10 15" class="heateor_sss_svg_stroke heateor_sss_no_fill" stroke-width="2" stroke="#fff"></path></svg></span></a></div><div class="heateorSssClear"></div></div>			</div><!-- .entry-content -->

	<footer class="entry-meta">
		This entry was posted in <a href="https://battingwithbimal.com/category/uncategorized/" rel="category tag">Uncategorized</a> and tagged <a href="https://battingwithbimal.com/tag/100-percent/" rel="tag">100 percent</a>, <a href="https://battingwithbimal.com/tag/australia-vs-pakistan/" rel="tag">Australia vs Pakistan</a>, <a href="https://battingwithbimal.com/tag/gives-his-best/" rel="tag">gives his best</a>, <a href="https://battingwithbimal.com/tag/hasan-ali/" rel="tag">Hasan Ali</a>, <a href="https://battingwithbimal.com/tag/lancashire/" rel="tag">Lancashire</a>, <a href="https://battingwithbimal.com/tag/match-winner/" rel="tag">match winner</a>, <a href="https://battingwithbimal.com/tag/middlesex/" rel="tag">Middlesex</a>, <a href="https://battingwithbimal.com/tag/pak-cricket/" rel="tag">Pak cricket</a>, <a href="https://battingwithbimal.com/tag/pak-cricket-news/" rel="tag">Pak cricket news</a>, <a href="https://battingwithbimal.com/tag/pak-vs-aus/" rel="tag">Pak vs Aus</a>, <a href="https://battingwithbimal.com/tag/pakistan/" rel="tag">Pakistan</a>, <a href="https://battingwithbimal.com/tag/pakistan-cricket/" rel="tag">Pakistan cricket</a>, <a href="https://battingwithbimal.com/tag/pakistan-cricket-news/" rel="tag">Pakistan cricket news</a>, <a href="https://battingwithbimal.com/tag/pakistan-vs-australia/" rel="tag">Pakistan vs Australia</a>, <a href="https://battingwithbimal.com/tag/shaheen-shah-afridi/" rel="tag">Shaheen Shah Afridi</a>. Bookmark the <a href="https://battingwithbimal.com/2022/05/19/we-all-know-hes-a-match-winner-shaheen-shah-afridi-on-pakistan-player-who-always-gives-100-percent/" title="Permalink to We all know he&#8217;s a match-winner, Shaheen Shah Afridi on Pakistan player who always gives 100 percent" rel="bookmark">permalink</a>.
			</footer><!-- .entry-meta -->
</article><!-- #post-## -->

				<nav role="navigation" id="nav-below" class="navigation-post clear">
		<h1 class="screen-reader-text">Post navigation</h1>

	
		<div class="nav-previous"><a href="https://battingwithbimal.com/2022/05/19/his-bowling-has-been-brilliant-shaheen-shah-afridi-on-pakistan-bowler-getting-back-to-his-best/" rel="prev"><span class="meta-nav">&larr;</span> His bowling has been brilliant, Shaheen Shah Afridi on Pakistan bowler getting back to his best</a></div>		<div class="nav-next"><a href="https://battingwithbimal.com/2022/05/19/getting-the-ball-to-reverse-cameron-green-on-pakistan-bowler-swinging-the-ball-at-145-kph/" rel="next">Getting the ball to reverse, Cameron Green on Pakistan bowler swinging the ball at 145 kph <span class="meta-nav">&rarr;</span></a></div>
	
	</nav><!-- #nav-below -->
	
			

	<div id="comments" class="comments-area">

	
	
	
	
		<div id="respond" class="comment-respond">
							<h3 id="reply-title" class="comment-reply-title">Leave a Reply					<small><a rel="nofollow" id="cancel-comment-reply-link" href="/2022/05/19/we-all-know-hes-a-match-winner-shaheen-shah-afridi-on-pakistan-player-who-always-gives-100-percent/#respond" style="display:none;">Cancel reply</a></small>
				</h3>
						<form id="commentform" class="comment-form">
				<iframe
					title="Comment Form"
					src="https://jetpack.wordpress.com/jetpack-comment/?blogid=33086731&#038;postid=159158&#038;comment_registration=0&#038;require_name_email=1&#038;stc_enabled=1&#038;stb_enabled=1&#038;show_avatars=1&#038;avatar_default=identicon&#038;greeting=Leave+a+Reply&#038;jetpack_comments_nonce=bceae3d2e9&#038;greeting_reply=Leave+a+Reply+to+%25s&#038;color_scheme=light&#038;lang=en_US&#038;jetpack_version=11.0-a.5&#038;show_cookie_consent=10&#038;has_cookie_consent=0&#038;token_key=%3Bnormal%3B&#038;sig=0be30f3dc04003badf8069c0f475800531ebd1f3#parent=https%3A%2F%2Fbattingwithbimal.com%2F2022%2F05%2F19%2Fwe-all-know-hes-a-match-winner-shaheen-shah-afridi-on-pakistan-player-who-always-gives-100-percent%2F"
											name="jetpack_remote_comment"
						style="width:100%; height: 430px; border:0;"
										class="jetpack_remote_comment"
					id="jetpack_remote_comment"
					sandbox="allow-same-origin allow-top-navigation allow-scripts allow-forms allow-popups"
				>
									</iframe>
									<!--[if !IE]><!-->
					<script>
						document.addEventListener('DOMContentLoaded', function () {
							var commentForms = document.getElementsByClassName('jetpack_remote_comment');
							for (var i = 0; i < commentForms.length; i++) {
								commentForms[i].allowTransparency = false;
								commentForms[i].scrolling = 'no';
							}
						});
					</script>
					<!--<![endif]-->
							</form>
		</div>

		
		<input type="hidden" name="comment_parent" id="comment_parent" value="" />

		
</div><!-- #comments -->

		
		</div><!-- #content -->
	</div><!-- #primary -->

	<div id="secondary" class="widget-area" role="complementary">
				<aside id="text-3" class="widget widget_text">			<div class="textwidget"><div style="width:100%;font-size:11px;line-height:11px;font-family:Verdana,Arial,Helvetica,sans-serif;color:#ddd;text-align:center" ><a rel="nofollow noopener" href="http://www.newsnow.co.uk/h/Sport/Cricket" target="newsnow" title="Click here for more Cricket news from NewsNow" style="text-decoration:none;border:0;"><img src="https://i0.wp.com/battingwithbimal.com/wp-content/uploads/2018/02/newsnow_aw.gif?w=670&#038;ssl=1" style="width:117px;height:47px;border:1px;display:inline-block;text-align: center;padding-bottom:2px" alt="As featured on NewsNow: Cricket news" data-recalc-dims="1"/></a ></br><a rel="nofollow noopener" href="http://www.newsnow.co.uk/h/Sport/Cricket" target="newsnow" title="Click here for more Cricket news from NewsNow" style="color:#ddd;text-decoration:none;border:0;"></a ><a href="http://www.newsnow.co.uk/h/Sport/Cricket" target="newsnow" title="Click here for more Cricket news from NewsNow" style="color:#ddd;text-decoration:none;border:0;" rel="nofollow noopener">Cricket News</a ><a rel="nofollow noopener" href="http://www.newsnow.co.uk/h/Sport/Cricket" target="newsnow" title="Click here for more Cricket news from NewsNow" style="color:#ddd;text-decoration:none;border:0;"> 24/7</a></div>
</div>
		</aside><aside id="search-5" class="widget widget_search">	<form method="get" id="searchform" class="searchform" action="https://battingwithbimal.com/" role="search">
		<label for="s" class="screen-reader-text">Search</label>
		<input type="search" class="field" name="s" value="" id="s" placeholder="Search &hellip;" />
		<input type="submit" class="submit" id="searchsubmit" value="Search" />
	</form>
</aside><aside id="blog_subscription-3" class="widget widget_blog_subscription jetpack_subscription_widget"><h1 class="widget-title"><span>Subscribe to Batting with Bimal</span></h1>
			<form action="#" method="post" accept-charset="utf-8" id="subscribe-blog-blog_subscription-3">
									<div id="subscribe-text"><p>Get all the latest Pakistan cricket news straight to your email!</p>
</div>
																			<div class="jetpack-subscribe-count">
						<p>
						Join 142,699 other subscribers						</p>
					</div>
										<p id="subscribe-email">
						<label id="jetpack-subscribe-label"
							class="screen-reader-text"
							for="subscribe-field-blog_subscription-3">
							Email Address						</label>
						<input type="email" name="email" required="required"
																					value=""
							id="subscribe-field-blog_subscription-3"
							placeholder="Email Address"
						/>
					</p>

					<p id="subscribe-submit"
											>
						<input type="hidden" name="action" value="subscribe"/>
						<input type="hidden" name="source" value="https://battingwithbimal.com/2022/05/19/we-all-know-hes-a-match-winner-shaheen-shah-afridi-on-pakistan-player-who-always-gives-100-percent/"/>
						<input type="hidden" name="sub-type" value="widget"/>
						<input type="hidden" name="redirect_fragment" value="subscribe-blog-blog_subscription-3"/>
												<button type="submit"
															class="wp-block-button__link"
																					name="jetpack_subscriptions_widget"
						>
							Subscribe						</button>
					</p>
							</form>
			
</aside><aside id="facebook-likebox-2" class="widget widget_facebook_likebox"><h1 class="widget-title"><span><a href="https://www.facebook.com/battingwithbimal">BattingwithBimal Facebook Page</a></span></h1>		<div id="fb-root"></div>
		<div class="fb-page" data-href="https://www.facebook.com/battingwithbimal" data-width="340"  data-height="130" data-hide-cover="false" data-show-facepile="false" data-tabs="false" data-hide-cta="false" data-small-header="false">
		<div class="fb-xfbml-parse-ignore"><blockquote cite="https://www.facebook.com/battingwithbimal"><a href="https://www.facebook.com/battingwithbimal">BattingwithBimal Facebook Page</a></blockquote></div>
		</div>
		</aside><aside id="rss_links-2" class="widget widget_rss_links"><h1 class="widget-title"><span>RSS Feed</span></h1><ul><li><a target="_self" href="https://battingwithbimal.com/feed/" title="Subscribe to posts">RSS - Posts</a></li></ul>
</aside>	</div><!-- #secondary -->

	</div><!-- #main -->

	<footer id="colophon" class="site-footer" role="contentinfo">
		<div class="site-info">
						<a></a>
			
					</div><!-- .site-info -->
	</footer><!-- #colophon -->
</div><!-- #page -->

<!--  -->
<script defer id='bilmur' data-provider='wordpress.com' data-service='atomic'  src='https://s0.wp.com/wp-content/js/bilmur.min.js?m=202220'></script>
		<div id="jp-carousel-loading-overlay">
			<div id="jp-carousel-loading-wrapper">
				<span id="jp-carousel-library-loading">&nbsp;</span>
			</div>
		</div>
		<div class="jp-carousel-overlay" style="display: none;">

		<div class="jp-carousel-container">
			<!-- The Carousel Swiper -->
			<div
				class="jp-carousel-wrap swiper-container jp-carousel-swiper-container jp-carousel-transitions"
				itemscope
				itemtype="https://schema.org/ImageGallery">
				<div class="jp-carousel swiper-wrapper"></div>
				<div class="jp-swiper-button-prev swiper-button-prev">
					<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
						<mask id="maskPrev" mask-type="alpha" maskUnits="userSpaceOnUse" x="8" y="6" width="9" height="12">
							<path d="M16.2072 16.59L11.6496 12L16.2072 7.41L14.8041 6L8.8335 12L14.8041 18L16.2072 16.59Z" fill="white"/>
						</mask>
						<g mask="url(#maskPrev)">
							<rect x="0.579102" width="23.8823" height="24" fill="#FFFFFF"/>
						</g>
					</svg>
				</div>
				<div class="jp-swiper-button-next swiper-button-next">
					<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
						<mask id="maskNext" mask-type="alpha" maskUnits="userSpaceOnUse" x="8" y="6" width="8" height="12">
							<path d="M8.59814 16.59L13.1557 12L8.59814 7.41L10.0012 6L15.9718 12L10.0012 18L8.59814 16.59Z" fill="white"/>
						</mask>
						<g mask="url(#maskNext)">
							<rect x="0.34375" width="23.8822" height="24" fill="#FFFFFF"/>
						</g>
					</svg>
				</div>
			</div>
			<!-- The main close buton -->
			<div class="jp-carousel-close-hint">
				<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
					<mask id="maskClose" mask-type="alpha" maskUnits="userSpaceOnUse" x="5" y="5" width="15" height="14">
						<path d="M19.3166 6.41L17.9135 5L12.3509 10.59L6.78834 5L5.38525 6.41L10.9478 12L5.38525 17.59L6.78834 19L12.3509 13.41L17.9135 19L19.3166 17.59L13.754 12L19.3166 6.41Z" fill="white"/>
					</mask>
					<g mask="url(#maskClose)">
						<rect x="0.409668" width="23.8823" height="24" fill="#FFFFFF"/>
					</g>
				</svg>
			</div>
			<!-- Image info, comments and meta -->
			<div class="jp-carousel-info">
				<div class="jp-carousel-info-footer">
					<div class="jp-carousel-pagination-container">
						<div class="jp-swiper-pagination swiper-pagination"></div>
						<div class="jp-carousel-pagination"></div>
					</div>
					<div class="jp-carousel-photo-title-container">
						<h2 class="jp-carousel-photo-caption"></h2>
					</div>
					<div class="jp-carousel-photo-icons-container">
						<a href="#" class="jp-carousel-icon-btn jp-carousel-icon-info" aria-label="Toggle photo metadata visibility">
							<span class="jp-carousel-icon">
								<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
									<mask id="maskInfo" mask-type="alpha" maskUnits="userSpaceOnUse" x="2" y="2" width="21" height="20">
										<path fill-rule="evenodd" clip-rule="evenodd" d="M12.7537 2C7.26076 2 2.80273 6.48 2.80273 12C2.80273 17.52 7.26076 22 12.7537 22C18.2466 22 22.7046 17.52 22.7046 12C22.7046 6.48 18.2466 2 12.7537 2ZM11.7586 7V9H13.7488V7H11.7586ZM11.7586 11V17H13.7488V11H11.7586ZM4.79292 12C4.79292 16.41 8.36531 20 12.7537 20C17.142 20 20.7144 16.41 20.7144 12C20.7144 7.59 17.142 4 12.7537 4C8.36531 4 4.79292 7.59 4.79292 12Z" fill="white"/>
									</mask>
									<g mask="url(#maskInfo)">
										<rect x="0.8125" width="23.8823" height="24" fill="#FFFFFF"/>
									</g>
								</svg>
							</span>
						</a>
												<a href="#" class="jp-carousel-icon-btn jp-carousel-icon-comments" aria-label="Toggle photo comments visibility">
							<span class="jp-carousel-icon">
								<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
									<mask id="maskComments" mask-type="alpha" maskUnits="userSpaceOnUse" x="2" y="2" width="21" height="20">
										<path fill-rule="evenodd" clip-rule="evenodd" d="M4.3271 2H20.2486C21.3432 2 22.2388 2.9 22.2388 4V16C22.2388 17.1 21.3432 18 20.2486 18H6.31729L2.33691 22V4C2.33691 2.9 3.2325 2 4.3271 2ZM6.31729 16H20.2486V4H4.3271V18L6.31729 16Z" fill="white"/>
									</mask>
									<g mask="url(#maskComments)">
										<rect x="0.34668" width="23.8823" height="24" fill="#FFFFFF"/>
									</g>
								</svg>

								<span class="jp-carousel-has-comments-indicator" aria-label="This image has comments."></span>
							</span>
						</a>
											</div>
				</div>
				<div class="jp-carousel-info-extra">
					<div class="jp-carousel-info-content-wrapper">
						<div class="jp-carousel-photo-title-container">
							<h2 class="jp-carousel-photo-title"></h2>
						</div>
						<div class="jp-carousel-comments-wrapper">
															<div id="jp-carousel-comments-loading">
									<span>Loading Comments...</span>
								</div>
								<div class="jp-carousel-comments"></div>
								<div id="jp-carousel-comment-form-container">
									<span id="jp-carousel-comment-form-spinner">&nbsp;</span>
									<div id="jp-carousel-comment-post-results"></div>
																														<form id="jp-carousel-comment-form">
												<label for="jp-carousel-comment-form-comment-field" class="screen-reader-text">Write a Comment...</label>
												<textarea
													name="comment"
													class="jp-carousel-comment-form-field jp-carousel-comment-form-textarea"
													id="jp-carousel-comment-form-comment-field"
													placeholder="Write a Comment..."
												></textarea>
												<div id="jp-carousel-comment-form-submit-and-info-wrapper">
													<div id="jp-carousel-comment-form-commenting-as">
																													<fieldset>
																<label for="jp-carousel-comment-form-email-field">Email (Required)</label>
																<input type="text" name="email" class="jp-carousel-comment-form-field jp-carousel-comment-form-text-field" id="jp-carousel-comment-form-email-field" />
															</fieldset>
															<fieldset>
																<label for="jp-carousel-comment-form-author-field">Name (Required)</label>
																<input type="text" name="author" class="jp-carousel-comment-form-field jp-carousel-comment-form-text-field" id="jp-carousel-comment-form-author-field" />
															</fieldset>
															<fieldset>
																<label for="jp-carousel-comment-form-url-field">Website</label>
																<input type="text" name="url" class="jp-carousel-comment-form-field jp-carousel-comment-form-text-field" id="jp-carousel-comment-form-url-field" />
															</fieldset>
																											</div>
													<input
														type="submit"
														name="submit"
														class="jp-carousel-comment-form-button"
														id="jp-carousel-comment-form-button-submit"
														value="Post Comment" />
												</div>
											</form>
																											</div>
													</div>
						<div class="jp-carousel-image-meta">
							<div class="jp-carousel-title-and-caption">
								<div class="jp-carousel-photo-info">
									<h3 class="jp-carousel-caption" itemprop="caption description"></h3>
								</div>

								<div class="jp-carousel-photo-description"></div>
							</div>
							<ul class="jp-carousel-image-exif" style="display: none;"></ul>
							<a class="jp-carousel-image-download" target="_blank" style="display: none;">
								<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
									<mask id="mask0" mask-type="alpha" maskUnits="userSpaceOnUse" x="3" y="3" width="19" height="18">
										<path fill-rule="evenodd" clip-rule="evenodd" d="M5.84615 5V19H19.7775V12H21.7677V19C21.7677 20.1 20.8721 21 19.7775 21H5.84615C4.74159 21 3.85596 20.1 3.85596 19V5C3.85596 3.9 4.74159 3 5.84615 3H12.8118V5H5.84615ZM14.802 5V3H21.7677V10H19.7775V6.41L9.99569 16.24L8.59261 14.83L18.3744 5H14.802Z" fill="white"/>
									</mask>
									<g mask="url(#mask0)">
										<rect x="0.870605" width="23.8823" height="24" fill="#FFFFFF"/>
									</g>
								</svg>
								<span class="jp-carousel-download-text"></span>
							</a>
							<div class="jp-carousel-image-map" style="display: none;"></div>
						</div>
					</div>
				</div>
			</div>
		</div>

		</div>
		<link rel='stylesheet' id='all-css-4fd2783b2e7c4ac0e6dd5802b072edc9' href='https://battingwithbimal.com/_static/??-eJyVjEsOwjAMBS+Ecan6WSGOglLXQgE3sepYuX6rqixZsJ03b6oC5VQ4FVTxV0yGby4a6INLnl3YkMKa3VjQalReYfI0C1/J7FL/eJ8DfMGvgGYRqIrqk0TC3cJiz4OeKpgyxXAUHsv9NvRt37XNMG4V+02H' type='text/css' media='all' />
<style id='ts_poll_special_488693-inline-css'>
:root{
					
					--tsp_a_c_488693-213 : #000000;
					--tsp_a_c_488693-214 : #000000;
					--tsp_a_c_488693-215 : rgb(0, 0, 0);
				}
				
								main.ts_poll_r_main_488693[data-tsp-bool="false"] > .ts_poll_answer_result[data-tsp-id="213"] > .ts_poll_answer_result_label > .ts_poll_answer_percent_line{
									background-color: var(--tsp_a_c_488693-213);
								}
								main.ts_poll_main_488693[data-tsp-bool="false"] > .ts_poll_answer[data-tsp-id="213"] > .ts_poll_answer_label {
									color: var(--tsp_a_c_488693-213);
								}
								
								main.ts_poll_r_main_488693[data-tsp-bool="false"] > .ts_poll_answer_result[data-tsp-id="214"] > .ts_poll_answer_result_label > .ts_poll_answer_percent_line{
									background-color: var(--tsp_a_c_488693-214);
								}
								main.ts_poll_main_488693[data-tsp-bool="false"] > .ts_poll_answer[data-tsp-id="214"] > .ts_poll_answer_label {
									color: var(--tsp_a_c_488693-214);
								}
								
								main.ts_poll_r_main_488693[data-tsp-bool="false"] > .ts_poll_answer_result[data-tsp-id="215"] > .ts_poll_answer_result_label > .ts_poll_answer_percent_line{
									background-color: var(--tsp_a_c_488693-215);
								}
								main.ts_poll_main_488693[data-tsp-bool="false"] > .ts_poll_answer[data-tsp-id="215"] > .ts_poll_answer_label {
									color: var(--tsp_a_c_488693-215);
								}
								
				
</style>
<script id='jetpack-facebook-embed-js-extra'>
var jpfbembed = {"appid":"249643311490","locale":"en_US"};
</script>
<script type='text/javascript'  src='https://battingwithbimal.com/_static/??-eJyFjssOwiAQRX9IOml9RBfGTzEUpu0UmCECrf69LJq4Mbq6m3NyzxqVEc7IGaIvI3GCGXPUxsGd2EBfyFuIk2ThbZpA3Mxpt37UPGHABAuloj3MCVgvNOpM8pdMjqLyxE4NYkpSAz03pd77YitcKSMhVF09MPrXl4Af7YM22Is4haFHu7m3cG1Ph/bS7Y/d+Q2wJWD6'></script>
<script id='heateor_sss_sharing_js-js-before'>
function heateorSssLoadEvent(e) {var t=window.onload;if (typeof window.onload!="function") {window.onload=e}else{window.onload=function() {t();e()}}};	var heateorSssSharingAjaxUrl = 'https://battingwithbimal.com/wp-admin/admin-ajax.php', heateorSssCloseIconPath = 'https://battingwithbimal.com/wp-content/plugins/sassy-social-share/public/../images/close.png', heateorSssPluginIconPath = 'https://battingwithbimal.com/wp-content/plugins/sassy-social-share/public/../images/logo.png', heateorSssHorizontalSharingCountEnable = 0, heateorSssVerticalSharingCountEnable = 0, heateorSssSharingOffset = -10; var heateorSssMobileStickySharingEnabled = 1;var heateorSssCopyLinkMessage = "Link copied.";var heateorSssUrlCountFetched = [], heateorSssSharesText = 'Shares', heateorSssShareText = 'Share';function heateorSssPopup(e) {window.open(e,"popUpWindow","height=400,width=600,left=400,top=100,resizable,scrollbars,toolbar=0,personalbar=0,menubar=no,location=no,directories=no,status")}
</script>
<script src='https://battingwithbimal.com/wp-content/plugins/sassy-social-share/public/js/sassy-social-share-public.js?ver=3.3.41' id='heateor_sss_sharing_js-js'></script>
<script id='ivory-search-scripts-js-extra'>
var IvorySearchVars = {"is_analytics_enabled":"1"};
</script>
<script id='jetpack-carousel-js-extra'>
var jetpackSwiperLibraryPath = {"url":"https:\/\/battingwithbimal.com\/wp-content\/plugins\/jetpack\/_inc\/build\/carousel\/swiper-bundle.min.js"};
var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"https:\/\/battingwithbimal.com\/wp-admin\/admin-ajax.php","nonce":"6e698408f7","display_exif":"1","display_comments":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"black","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","copyright":"Copyright","comment_registration":"0","require_name_email":"1","login_url":"https:\/\/battingwithbimal.com\/wp-login.php?redirect_to=https%3A%2F%2Fbattingwithbimal.com%2F2022%2F05%2F19%2Fwe-all-know-hes-a-match-winner-shaheen-shah-afridi-on-pakistan-player-who-always-gives-100-percent%2F","blog_id":"1","meta_data":["camera","aperture","shutter_speed","focal_length","copyright"]};
</script>
<script type='text/javascript'  src='https://battingwithbimal.com/_static/??-eJx9jksOwjAMBS9E6iIqPgvEUVCaWNRp4oQ4puL2bNoViO0bvdEsxbjMDblBifogFgjYinUz3IkdjErRQ6QZBZ6KipNlH7F2ibgLslu+/9Z7I2irm0zLJiErFB0jOQgC9Mr1veI/jh8NztasgnFjZhtWzS1d98fhfOgvp374AJ9gUAc='></script>
<script src='https://battingwithbimal.com/wp-content/plugins/poll-wp/public/js/ResizeSensor.js?ver=1652924358' id='TS PollResizeSensor-js'></script>
<script src='https://battingwithbimal.com/wp-content/plugins/poll-wp/public/js/ElementQueries.js?ver=1652924358' id='TS PollElementQueries-js'></script>
<script id='ts_poll_js_488693-js-extra'>
var ts_poll_ajax_488693 = {"ts_poll_ajax_url":"https:\/\/battingwithbimal.com\/wp-admin\/admin-ajax.php"};
</script>
<script src='https://battingwithbimal.com/wp-content/plugins/poll-wp/public/js/ts_poll-content.js?ver=1652924358' id='ts_poll_js_488693-js'></script>
<script id='ts_poll_js_488693-js-after'>

    (function($) {
      "use strict";
      
          $(document).on("click", `footer.ts_poll_footer_488693  #ts_poll_vote_button`, function(event) {
            var tsp_checked_array = [];
            setTimeout(() => {
              $(`main.ts_poll_main_488693 input[name="ts_poll_all488693"]`).each(function(){
                if($(this).is(":checked")){
                  tsp_checked_array.push($(this).val());
                }
              });
              if(tsp_checked_array.length === 0 || event.type != "click"){
                return;
              }
              $.ajax({
                url: ts_poll_ajax_488693.ts_poll_ajax_url,
                data: {
                  action: "tsp_vote_function",
                  tsp_vote_nonce: $(`#tsp_vote_nonce_field_488693`).val(),
                  tsp_id : 35,
                  tsp_change_id : 488693,
                  tsp_checkeds : tsp_checked_array.join("|"),
                },
                beforeSend: function() {
                  $("form.ts_poll_form_488693 div.ts_poll_loading").attr("style","display:flex;");
                },
                type: "POST",
              }).done(function(response) {
                if (response.success === true) {
                  $("form.ts_poll_form_488693 footer").remove();
                  $("form.ts_poll_form_488693 div.ts_poll_loading").removeAttr("style");
                    tsp_change_results_488693(response.data); tsp_show_results_488693();
                }else{
                  $("form.ts_poll_form_488693 div.ts_poll_loading").removeAttr("style");
                }
              }).fail(function() {
                $("form.ts_poll_form_488693 div.ts_poll_loading").removeAttr("style");
              });
            }, 100);
          });
          
    })(jQuery);
    
</script>
	<iframe src='https://widgets.wp.com/likes/master.html?ver=202220#ver=202220' scrolling='no' id='likes-master' name='likes-master' style='display:none;'></iframe>
	<div id='likes-other-gravatars'><div class="likes-text"><span>%d</span> bloggers like this:</div><ul class="wpl-avatars sd-like-gravatars"></ul></div>
	
		<!--[if IE]>
		<script type="text/javascript">
			if ( 0 === window.location.hash.indexOf( '#comment-' ) ) {
				// window.location.reload() doesn't respect the Hash in IE
				window.location.hash = window.location.hash;
			}
		</script>
		<![endif]-->
		<script type="text/javascript">
			(function () {
				var comm_par_el = document.getElementById( 'comment_parent' ),
					comm_par = ( comm_par_el && comm_par_el.value ) ? comm_par_el.value : '',
					frame = document.getElementById( 'jetpack_remote_comment' ),
					tellFrameNewParent;

				tellFrameNewParent = function () {
					if ( comm_par ) {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=33086731&postid=159158&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=identicon&greeting=Leave+a+Reply&jetpack_comments_nonce=bceae3d2e9&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=11.0-a.5&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=0be30f3dc04003badf8069c0f475800531ebd1f3#parent=https%3A%2F%2Fbattingwithbimal.com%2F2022%2F05%2F19%2Fwe-all-know-hes-a-match-winner-shaheen-shah-afridi-on-pakistan-player-who-always-gives-100-percent%2F" + '&replytocom=' + parseInt( comm_par, 10 ).toString();
					} else {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=33086731&postid=159158&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=identicon&greeting=Leave+a+Reply&jetpack_comments_nonce=bceae3d2e9&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=11.0-a.5&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=0be30f3dc04003badf8069c0f475800531ebd1f3#parent=https%3A%2F%2Fbattingwithbimal.com%2F2022%2F05%2F19%2Fwe-all-know-hes-a-match-winner-shaheen-shah-afridi-on-pakistan-player-who-always-gives-100-percent%2F";
					}
				};

				
				if ( 'undefined' !== typeof addComment ) {
					addComment._Jetpack_moveForm = addComment.moveForm;

					addComment.moveForm = function ( commId, parentId, respondId, postId ) {
						var returnValue = addComment._Jetpack_moveForm( commId, parentId, respondId, postId ),
							cancelClick, cancel;

						if ( false === returnValue ) {
							cancel = document.getElementById( 'cancel-comment-reply-link' );
							cancelClick = cancel.onclick;
							cancel.onclick = function () {
								var cancelReturn = cancelClick.call( this );
								if ( false !== cancelReturn ) {
									return cancelReturn;
								}

								if ( ! comm_par ) {
									return cancelReturn;
								}

								comm_par = 0;

								tellFrameNewParent();

								return cancelReturn;
							};
						}

						if ( comm_par == parentId ) {
							return returnValue;
						}

						comm_par = parentId;

						tellFrameNewParent();

						return returnValue;
					};
				}

				
				// Do the post message bit after the dom has loaded.
				document.addEventListener( 'DOMContentLoaded', function () {
					var iframe_url = "https:\/\/jetpack.wordpress.com";
					if ( window.postMessage ) {
						if ( document.addEventListener ) {
							window.addEventListener( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								frame.style.height = event.data + 'px';
							});
						} else if ( document.attachEvent ) {
							window.attachEvent( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								frame.style.height = event.data + 'px';
							});
						}
					}
				})

			})();
		</script>

		<script src='https://stats.wp.com/e-202220.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:11.0-a.5',blog:'33086731',post:'159158',tz:'8',srv:'battingwithbimal.com',hp:'atomic',ac:'2',amp:'0'} ]);
	_stq.push([ 'clickTrackerInit', '33086731', '159158' ]);
</script>

</body>
</html>
<!--
	generated 126 seconds ago
	generated in 0.222 seconds
	served from batcache in 0.002 seconds
	expires in 174 seconds
-->
